PowerHA: PREVENT EMAIXOS (HARMAD) FROM RUNNING IN HACMP ON AIX 6.1

Many thanks to a great customer for having me add this to the blog…

We’ve recently run into this and it’s pretty much benign, but annoying.  The apar’s not new (2010), but our version of Hacmp did not have the apar in it.  Only caveat I found is that it appears this subsystem is still required for Oracle 9i (which explains why it’s not part of the standard release of hacmp).

Link:  http://www.ibm.com/support/docview.wss?uid=isg1IZ86787

IZ86787: PREVENT EMAIXOS (HARMAD) FROM RUNNING IN HACMP ON AIX 6.1

Error description

This is a code change in RSCT to stop running the emaixos

subsystem (harmad process) in PowerHA clusters on AIX 6.1.

See APAR IZ47424 for more background.

Problem summary

While existing levels of PowerHA may still be supporting

applications which are dependent on the RSCT subsystem

“emsvcs” (haemd process), its supporting subsystem “emaixos”

(harmad process) is not needed even on those clusters.

 

This harmad process has also been the source of most of the

recent incompatability issues with the latest levels of

AIX 6.1, generating error messages or core dumps which demand

attention and time from system admins even though the process

itself no longer provides useful services.

Leave a Reply